Ryzom (http://forums.ryzom.com/index.php)
-   Technical Support (http://forums.ryzom.com/forumdisplay.php?f=15)
-   -   [FAQ] Networking, Firewalls & Routers (Please wait...) (http://forums.ryzom.com/showthread.php?t=7650)

lawrence December 4th, 2004 08:17 PM

[FAQ] Networking, Firewalls & Routers (Please wait...)
I. Firewalls that are known to work with Ryzom
You may still need to customise the ports manually to get things to work. You may have to dig out the documentation on this as we do not have first hand experience in configuring all of these.

II. Firewalls that are known to cause issues
  • Norton Internet Security 2004 (NIS)
Occasionally causes problems with certain Ryzom .dll libraries. The .dll problem does no longer occur in the 2005 edition. However, NIS in general is known to be CPU and Memory intensive, which may slow down your overall system performance.
  • Tiny Personal Firewall (TPF)
This firewall has problems with the Microsoft Installer. It also causes issues with the hardware mouse cursor feature. If you want to use TPF and SoR, we recommend that you disable its 'Windows security' module first.
  • Microsoft ISA Firewall
This firewall does seem to have issues with letting Ryzom even start.
If someone gets it figured out please let us know how and we will include the advice here.

III. Outgoing Ports

The following ports are used by Ryzom. If you experience problems with connecting to the game, you may have to open the following outgoing ports manually in your firewall(s) and network router:
UDP 47851 to 47860 (game)
TCP 80 (support)
TCP 443 (account creation from launcher)
TCP 40916 (login/patch)
TCP 43434 (patch)
TCP 48851 to 48860 (Ring)
TCP 50000 (forum)
English CeB port: TCP 6001

IV. General Advice

- Grant "client_ryzom_rd.exe" and "client_background_downloader_rd.exe" permanent rights to send and receive data
- Disable any real-time Anti-Virus protection features and scheduled Anti-Virus scans while playing Saga Of Ryzom.
- After a server patch the server IP and port will usually change so you may have to redo your entry for Ryzom
- Disable other network apps such as BitTorrent or streaming audio as they can severly impact your net performance
- if Ryzom 'disappears' when launching, or takes a long time to connect then you probably have a firewall or possibly a router issue. Try restarting your system or granting the game client full access

V. An example on how to enable port triggering for LinkSys router

[Posted by trodofor on 05 Apr 2004 23:23. Another Solution for 10 Minute Disconnects]
Ok, I am one of the unfortunate people who have experienced the 10-minute disconnect problem, and I have come up with another temporary fix. Before you start saying why this won’t work (because it has to do with port forwarding) try it, or read the post. First, for those who just want to ‘get in to the game’, I’ll list what I did to make it work on my machine and network. Then I’ll try to explain why this works and why it is happening (to the best of my knowledge) so that it may help Nevrax and whoever else come up with a fix (if they do not have one already waiting to be patched).

I have a Linksys BEFW11S4 version one. It would first be a good idea to make sure that you have the latest firmware for your router. If you own a non-Linksys router and have problems with disconnects, this technique may still work in principle, but the steps are going to be different.

How to do it:
1. Go to in your web browser.
- some routers may use - consult your documentation
2. User name is usually blank, but the password is whatever you set it to be (I believe it is admin by default)
3. Click on the ‘Advanced’ tab
4. Click on the ‘Forwarding’ tab
5. At the bottom, there is a button for ‘Port Triggering’. Click that to open the port triggering form.
6. On that form, enter whatever you want for ‘Application’ (I used Ryzom).
7. On that same line, for ‘Trigger Port Range’ enter 47851 for start and 47860 for end
8. Again, same line, under the ‘Incoming Port Range’ enter 1000 and 3000 in those boxes
9. Click ‘Apply’, and then close your web browser.

If you have been running your computer a while, or have played Ryzom or other games/network programs since you have turned on your computer, you might need to restart your computer before you play Ryzom. Also, if it worked earlier, then suddenly disconnects you, restart your computer before starting Ryzom again. Find more information and answers in this thread.

http://www.portforward.com is a handy site for seeing how to enable port forwarding and triggering.

Zerlin April 17th, 2005 11:31 PM

Disconnect after Teleport or Please wait...
Players with Windows XP SP2 seem to be having the D/C or crash problem after teleporting. Knowing that the teleport is instantaneous and that all the time spent waiting is for the new terrain to load, it became obvious that a player could sit there for 10-20 seconds with no network connection. Seems that SP2 firewall likes to close the open network ports. So the solution is to make sure the UDP 47851 port is in the firewall exceptions list.

Open Control Panel, select Windows Firewall. Click on the Exceptions tab. Click the Add Port button. Enter 47851 and select UDP. Click Okay.

Currently you will need to do this for all 10 ports in the range UDP 47851 to 47860.

Zerlin June 22nd, 2005 06:33 PM

Tracing network path problems
If you want to check the integrity of our network path you can do it by running a tracert su1.ryzom.com in a command window.
The easiest thing to do is use the freeware ping plot utility from PingPlotter which is very easy to use.

If you are seeing anything in the column marked PL% you will have problems logging in and will have lag in the game.
Try entering another site like www.microsoft.com to see if you get packet loss there.
If you do not get packet loss to other sites, then hopefully the PL to the Ryzom site is intermittent and then you have nothing to do but wait for it to clear. If you do have problems in reaching other sites as well then you may have some network issues in your LAN or system that need to be looked into.
If the PL to su1.ryzom.com does not clear, then you should first check with your ISP (one player had their PL mysteriously disappear after talking with their ISP.)

If nothing happens after checking with your ISP, then email support-ee@ryzom.com with a copy of the ping plot report (use the Edit menu and select 'Copy as Text' and then paste it into your email) and we will see if there is anything that can be done from our end.

asyne November 14th, 2005 07:52 AM

nVidia Network Manager seems causes problems with Ryzom patching
Just an FYI for Lawrence, Zerlin, whoever, when I had the nVidia ForceWare Network Access Manager is installed (it comes packaged with nForce drivers), ryzom_recover.exe experienced some kind of blockage that prevented parts being downloaded from completing. The download speed for the program was also undercut, with speeds between 2,000 and 3,000 before removing the Manager, and 150k and up (what I normally get) after.

Also, a Microsoft Visual C++ runtime error that I was getting when patching went away after I removed the program.

(Ack, I can't belive I didn't notice the cruddy grammar I had for the thread title until I posted. Bad me!)

grelka January 28th, 2006 05:10 PM

US Robotics Wired Router Fix
I just got a new US Robotics USR8004 wired router and easily integrated my two home computers into it and got online seamlessly. However, when I tried to play Ryzom, one of two things happened:

1. The game would not fully load (would get to the dreaded last graphic that never fills in on the progress bar)

2. Logs in but goes into permanent lag within a few minutes

I wrote to US Robotics and although they responded, their suggestion did not work. I then tried opening the recommended TCP and UDP ports for Ryzom and rebooted the router and that didn't work.

I then did a thorough study of all of the settings on the router and noticed it had an "extra" firewall layer in the "Miscellaneous Items" of the config page. It also said if this extra layer of firewall were disabled, it would still have a basic NAT firewall.

So, I turned off the extra firewall layer and rebooted the router and got on Ryzom. Voila! No problems over the next two hours. When I got done with Ryzom, I chose to turn the extra firewall layer back on for web browsing.

Anyway, I thought I'd pass this on in case anyone else runs into this problem because the fix is surprisingly easy.

All times are GMT +2. The time now is 11:28 AM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Ryzom forums are part of the SoR service and subject to the EULA and Code of Conduct.